Date: 2003-08-17 01:11:14
En réponse à Jeff Garland <jeff_at_[hidden]>:
> On Sat, 16 Aug 2003 23:31:05 -0400, Jeremy B. Maitin-Shepard wrote
> > > Yes, of course, it is not really a union either. I think
> > > merge_inclusive is fine.
> > How about "maximize" or "maximize_duration" or just "max" or
> > "max_duration"?
> Thx for the ideas, but...
> I'm leary of these b/c this is an operation on a period not a duration.
> max is way too overloaded; and still not sure it explains the operation. I
> still haven't heard a name that really strikes me as really good.
I just wanted to mention that the interval library names this operation "hull".
It is a mathematically defined term since the operation is indeed a convex hull.
Just my two eurocents,
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk