Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-08-21 22:01:36

Beman Dawes <bdawes_at_[hidden]> writes:

> At 04:49 PM 8/21/2003, David Abrahams wrote:
> >
> >This name, too, seems sorta redundant. Seriously, my mind forgets
> >the "file_" in the middle every time I use it and I've had a bunch of
> >stupid compiler errors because of it. Is there any reason
> >"native_file_string" is superior to "native_string"?
> To clearly distinguish between "native_file_string()" and
> "native_directory_string()".

Grrr. OpenVMS certainly throws a wrench in this model, doesn't it?

Should we give paths knowledge of whether they refer to files or
directories, and construct them with functions like file_path() and
directory_path(), so that there can be a single way to "go native"?

I can think of only one context in which I don't know whether I'm
working with a file or directory: when iterating over the contents of
a directory. In that context I'll almost certainly want to know
whether I've got a file or directory pretty soon anyway.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at