Boost logo

Boost :

From: Alexander Nasonov (alnsn-mycop_at_[hidden])
Date: 2003-09-02 07:44:28

Douglas Gregor wrote:
> Between the two: adaptable_any is better, I think.
> Because I like throwing wrenches: have you considered a very different
> name such as "polymorphic" or just "poly". The idea is that we read:
> poly<less_than_comparable, equality_comparable>
> as "a type that is polymorphic over all less_than_comparable &
> equality_comparable types."
> And because I'm feeling silly and reading a book on lattice theory... it
> could also be named models_meet, as in "a type that models the meet of the
> following concepts in the concept lattice".
> Doug

Both suggestions are too extreme, IMHO.

Alexander Nasonov
Remove minus and all between minus and at from my e-mail for timely response

Boost list run by bdawes at, gregod at, cpdaniel at, john at