Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-09-03 08:51:30

"Jeff Garland" <jeff_at_[hidden]> writes:

> On Tue, 02 Sep 2003 16:50:09 -0400, David Abrahams wrote
>> I'm just getting started with the date_time library, and I think I'm
>> gonna like it.
> Let's hope so!
>> I have some quibbles with the naming choices though
>> (shocking! me of all people!) For example, why is the nested
>> namespace called posix_time instead of, simply, posix? Once you're
> Seemed clearer to me that it would be limited to time and not presume to
> encompass all of posix.
>> in a date_time context it seems to me that _time adds nothing.
>> Similarly, what's the "p" in ptime stand for? I can guess, but I
>> can guess it's also redundant ;-)
> My first choice was 'time'. However, as I recall I ran into some nasty macros
> that interfered with that name, sigh. time_point would be another
> possibility, but it is longer. I'm certainly open to suggestions...

Disable the macros where neccessary? You can do it temporarily and
provide an alias typedef.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at