Boost logo

Boost :

From: Matthew Towler (towler_at_[hidden])
Date: 2003-09-03 09:14:30

Beman Dawes wrote:
> Are you using from CVS or your own script?

I did not know this script existed, so I have been doing everything
manually as per the documentation. on
and making the obvious syntactic adjustments for unix

> The kinds of troubles you describe can be caused by (1) wrong
> BOOST_ROOT, (2) failing to cd $boost_root/status before running the
> tests, (3) wrong arguments to the actual programs.
> >...
> >
> >I checked that BOOST_ROOT was set to
> >/scratch8/buildman/builds/linux-boost-1.30.2/0.2/status/bin
> That looks very suspicious and is almost certainly wrong.

Yes it is wrong, sorry that was a cut-and-paste error on my part when
writing this email.

> What I would expect is BOOST_ROOT set to:
> /scratch8/buildman/builds/linux-boost-1.30.2

yes it was, sorry about that


One thing I noticed is that this documentation indicates setting a
BOOST_ROOT environment variable, whilst uses boost_root, I
was under the impression that case mattered - or is this irrelevant as
boost_root is always passed into the executables on the command line
rather than automatically referred to?

I retried the processing of the regression test results using the script and got exactly the same result from
'compiler_status', namely

*** Error: std::runtime_error: boost::filesystem::directory_iterator
No such file or directory

BOOST_ROOT (and boost_root in the script) were set to

so I believe it is the processing program that is adding the spurious
'0_2' to the path.

I also tried the script on IRIX (with the mipspro compiler),
with a script adjusted to set test_tools and toolset to mipspro. I got
the following (good) output for the processing

processing the regression test results for mipspro:
Usage: bjam [bjam-args] | process_jam_log [locate-root]
  locate-root is the same as the bjam ALL_LOCATE_TARGET
  parameter, if any. Default is boost-root.
boost_root: /local/buildman/builds/boost-1.30.2
locate_root: /local/buildman/builds/boost-1.30.2
no errors detected
generating html tables:
Using /local/buildman/builds/boost-1.30.2/status/bin/config_test.test to
determine compilers
no errors detected

However when I look at the generated webpage (cs-IRIX64.html), most of
the tests are marked as missing. e.g. for regex regex_grep_example_1, 2,
3, are marked as Missing, whilst regex_grep_example_4 is a Pass.

Looking at the corresponding regress.log file, all of these four tests
passed - and when located in $BOOST_ROOT running
find . -name "*.xml" | grep example_

so it would appear the output is there - so I do not understand why the
tests are Missing.

Thanks for any help


Boost list run by bdawes at, gregod at, cpdaniel at, john at