Boost logo

Boost :

From: Paul A. Bristow (boost_at_[hidden])
Date: 2003-09-03 16:14:20

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]]On Behalf Of David Abrahams
| Sent: Wednesday, September 03, 2003 8:08 PM
| To: boost_at_[hidden]
| Subject: [boost] Re: [date_time] time_duration
| > Yikes! They probably all should be plural. Problem is the abbreviated
| > 'millisecs' doesn't sound right to me, so perhaps that's the reason....
| Well, abbrevs just don't sound right. Bite the bullet and use the
| full names, please!

Yes - millseconds, microsconds, nanoseconds ... please.

And time_point shounds VERY MUCH better to me (than ptime or time).

And I suggest






first_day_of_week_after my_date(Monday); will now make sense to almost any

"Boost has always favoured clarity over curtness"


PS Isn't time from C time in global namespace? Not a macro but still a PITA!

PPS It would be great if Jeff could find the time to produce version 2. There
is so much that seems right to me. Forget about MSVC 6 and gcc 2.x and break

Paul A Bristow, Prizet Farmhouse, Kendal, Cumbria, LA8 8AB UK
+44 1539 561830 Mobile +44 7714 33 02 04

Boost list run by bdawes at, gregod at, cpdaniel at, john at