Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2003-09-04 08:51:47

> Yes - millseconds, microsconds, nanoseconds ... please.

> And time_point shounds VERY MUCH better to me (than ptime or time).

My only worry about time_point is then things like local_time or
multiprecision_time (no these don't currently exist in the library) would
probably need to be local_time_point and multiprecision_time_point. In the
context of other time types adding 'point' doesn't sound appealling.

> And I suggest
> first_day_of_week_after
> first_day_of_week_before
> last_day_of_week_in_month
> first_day_of_week_in_month
> so
> first_day_of_week_after my_date(Monday); will now make sense to
> almost any reader.

Done. Once again the existing names will be deprecated.

> PS Isn't time from C time in global namespace? Not a macro but still
> a PITA!

Very well could be...
> PPS It would be great if Jeff could find the time to produce version
> 2.

Well I continue to actively improve the library based on user input and issues
that I am aware of.

> There is so much that seems right to me. Forget about MSVC 6
> and gcc 2.x and break out!

To large extent that has already occured...


Boost list run by bdawes at, gregod at, cpdaniel at, john at