Boost logo

Boost :

From: Eric Friedman (ebf_at_[hidden])
Date: 2003-09-07 22:15:48


(Note: this message refers to code set for release in Boost 1.31.)

I've begun to question whether boost::incomplete is the best name for that
class. I now believe it should be called boost::recursive_wrapper, but I'd
first like to know if anyone disagrees with my reasoning.

First, there is no problem providing an incomplete type to variant (provided
the variant template is not instantiated before the incomplete type is

Second, I see no real use for incomplete types in variant outside its
utility in allowing recursive variant types. That is, it seems then that the
only significant use-case for boost::incomplete is in breaking cyclical
dependencies, enabling recursive types.

I therefore propose the name boost::recursive_wrapper as a more appropriate
name for the class. In addition to being more descriptive IMO, the name
echoes boost::recursive_variant.

I'd appreciate input though before making the change. I don't know if anyone
else has uses for boost::incomplete that I have not envisioned.


Boost list run by bdawes at, gregod at, cpdaniel at, john at