From: David Abrahams (dave_at_[hidden])
Date: 2003-10-06 22:40:39
"Thorsten Ottosen" <nesotto_at_[hidden]> writes:
> Hi All,
> folowwing the discussion regarding the implementation of the container
> traits, I have know reimplemented
> everything from scratch using partial template specialization were
> avaliable. Also, (and most importantly) the
> traits have been refactered into single traits instead of monolithic traits.
Was it uncomfortable? Easy? Messy?
> I 'm considering to change the naming of the traits and need some advise.
> Currently they are called:
> I leaning towards this instead
> which seems much more elegant. My fear was clashing with names like
> std::iterator, but shouldn't this be solved by full
> qualification boost::iterator. Any thoughts?
We already have a boost::iterator; see boost/iterator.hpp.
I suggest a nested namespace, e.g.
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk