Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-10-07 00:16:24


"David Abrahams" <dave_at_[hidden]> wrote in message
news:ud6d9u348.fsf_at_boost-consulting.com...
> "Thorsten Ottosen" <nesotto_at_[hidden]> writes:

> > folowwing the discussion regarding the implementation of the container
> > traits, I have know reimplemented
> > everything from scratch using partial template specialization were
> > avaliable. Also, (and most importantly) the
> > traits have been refactered into single traits instead of monolithic
traits.
>
> Thanks!
>
> Was it uncomfortable? Easy? Messy?

First of all, I like the new approach. I took me a day to do, but the
resulting code seems
less messy.

> > I 'm considering to change the naming of the traits and need some
advise.
> > Currently they are called:
> >
> > container_iterator<C>::type
> > container_const_iterator<C>::type
> >
> > I leaning towards this instead
> >
> > iterator<C>::type
> > const_iterator<C>::type
> >
> > which seems much more elegant. My fear was clashing with names like
> > std::iterator, but shouldn't this be solved by full
> > qualification boost::iterator. Any thoughts?
>
> We already have a boost::iterator; see boost/iterator.hpp.
>
> I suggest a nested namespace, e.g.
>
> boost::containers::iterator<C>::type
> boost::containers::const_iterator<C>::type

good idea.

cheers

Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk