From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-10-08 10:21:35
> > I 'm considering to change the naming of the traits and need some
> > advise. Currently they are called:
> > container_iterator<C>::type
> > container_const_iterator<C>::type
> > I leaning towards this instead
> > iterator<C>::type
> > const_iterator<C>::type
> > which seems much more elegant. My fear was clashing with names like
> > std::iterator, but shouldn't this be solved by full
> > qualification boost::iterator. Any thoughts?
> I prefer the
> convention for "accessor metafunctions".
I like it too, it reads nicely.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk