Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-10-10 07:59:52

"Eric Niebler" <eric_at_[hidden]> wrote in message
> Thorsten Ottosen wrote:
> >
> > I do think it should be called FOR_EACH because it's more like a new
> > keyword. I can't imagine that will clash with anything.
> >
> IMO we should stick to the Boost naming convention and keep the BOOST_
> prefix. There is nothing stopping users from #define-ing it to something
> shorter if they choose, but it doesn't work the other way 'round.

why not?

// file my_for_each.hpp
#include <boost/for_each.hpp>

#define XX FOR_EACH
#endef FOR_EACH



Boost list run by bdawes at, gregod at, cpdaniel at, john at