|
Boost : |
From: Brian McNamara (lorgon_at_[hidden])
Date: 2003-10-23 22:25:00
On Thu, Oct 23, 2003 at 11:07:34PM -0400, David Abrahams wrote:
> Rene Rivera <grafik.list_at_[hidden]> writes:
> > 3. I'll gladly add ASAP, in which case; Is "unused_variable" a reasonable
> > name?
>
> Reasonable, though "no_unused_warning" might be more self-documenting.
Everyone has opinions about names, so I'll share mine.
I think something long like
disable_unused_variable_warning
is better.
In fact, I don't know if there are other types of warnings people try to
disable with code-tricks like these, but it might even make sense to
make it be
disable_warning::unused_variable
Even if this is the only such entity, I kinda like the way the code
reads with the "::" in it. In general, anything in the
"disable_warning" namespace would be "code with no effect" stuff like
this example.
-- -Brian McNamara (lorgon_at_[hidden])
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk