Boost logo

Boost :

From: Rene Rivera (grafik.list_at_[hidden])
Date: 2003-10-23 23:26:23


[2003-10-23] Brian McNamara wrote:

>On Thu, Oct 23, 2003 at 11:07:34PM -0400, David Abrahams wrote:
>> Rene Rivera <grafik.list_at_[hidden]> writes:
>> > 3. I'll gladly add ASAP, in which case; Is "unused_variable" a
reasonable
>> > name?
>>
>> Reasonable, though "no_unused_warning" might be more self-documenting.
>
>Everyone has opinions about names, so I'll share mine.
>
>I think something long like
>
> disable_unused_variable_warning
>
>is better.
>
>In fact, I don't know if there are other types of warnings people try to
>disable with code-tricks like these, but it might even make sense to
>make it be
>
> disable_warning::unused_variable
>
>Even if this is the only such entity, I kinda like the way the code
>reads with the "::" in it. In general, anything in the
>"disable_warning" namespace would be "code with no effect" stuff like
>this example.

I kinda like the disable_warning:: version also... As it lets you also:

    using namespace boost::disable_warning;
    ...

:-)

-- grafik - Don't Assume Anything
-- rrivera (at) acm.org - grafik (at) redshift-software.com
-- 102708583 (at) icq


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk