Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-10-26 01:00:17

"Jessie Hernandez" <jessie_at_[hidden]> wrote in message
> Thorsten Ottosen wrote:
> > Naming in general; prefer read_socket() to rdsocket(); prefer protocol()
> > to proto() prefer is_connected() to connected(), set_port() to port()
> >
> 1) rdsocket was named to resemble rdbuf in the fstream classes (this can
> changed, though, if many would like).
> 2) protocol() cannot be renamed because there is a class named protocol.

I think there was a member function which was called proto(). Shouldn't you
be able to rename that?

> 3) is_connected, etc. was chosen also to resemble the functions in the
> basic_ios class (they are named good(), eof(), fail(), and bad()).

Ok, I looked at fstream::is_open().



Boost list run by bdawes at, gregod at, cpdaniel at, john at