Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2003-11-01 18:27:00

On Sat, Nov 01, 2003 at 10:03:36AM -1000, David Abrahams wrote:
> Pavol Droba <droba_at_[hidden]> writes:


> I think it should be moved outside and documented as a separate
> utility. It's valuable to be able to pass containers around. It
> would be good if you'd look over the functionality of half_open_range
> and see if there's anything worth stealing.
Ok this seems reasonable. There is one more thing left open: the name.

Is "iterator_range" ok, or should it be renamed to "range"?
There is a set of support utilities, which has currently names like
make_range, copy_range and etc.
Either these functions are renamed to make_iterator_range (and etc.),
or the class will have to be renamed to "range".

My question to public is: What is prefered solution?



Boost list run by bdawes at, gregod at, cpdaniel at, john at