Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2003-11-03 06:33:22

> Is it planed to be merged in main trank?

Yes, this week I believe.

> the "build_for_distribution" branch, and see
> Where could I find usage docs on stage and install rules?

I think Rene and Beman are going to write them this week - or at least
that's the plan. I also have a short tutorial on some of the config /
autolink stuff in the works.

> > libs/regex/build/Jamfile for an example of a lib-specific-Jamfile that
> > creates files with the same naming convention, and in the same
> What is 'n' in BOOST_LIB_RT_OPT?

STLPort without STLPort iostreams, needs documenting obviously :-)

> As per our discussion could we remove this lib prefix? Who should agree?

We need something to differentiate between static libraries and dll import
libraries, I suppose a "static_" prefix would actually be my preference.
One thing though - it is *extremely* painful to change and then test this
(as well as modifying and testing the header, I have a lot of regex
makefiles that also have to change, and then be tested with every possible
build variant you can imagine :-( ), changing the name of the prefix
wouldn't be too bad for me though if that's really desirable. To be honest
I'm not too unhappy with the current "lib" prefix though.


Boost list run by bdawes at, gregod at, cpdaniel at, john at