Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2003-11-04 07:02:37

> > As per our discussion could we remove this lib prefix? Who should agree?
> We need something to differentiate between static libraries and dll import
> libraries, I suppose a "static_" prefix would actually be my preference.
> One thing though - it is *extremely* painful to change and then test this
> (as well as modifying and testing the header, I have a lot of regex
> makefiles that also have to change, and then be tested with every possible
> build variant you can imagine :-( ), changing the name of the prefix
> wouldn't be too bad for me though if that's really desirable. To be
> I'm not too unhappy with the current "lib" prefix though.

And on second thoughts I'm not sure it's possible the remove the "lib"
prefix if we also want to ensure a consistent naming scheme across Unix and
Windows platforms.


Boost list run by bdawes at, gregod at, cpdaniel at, john at