Boost logo

Boost :

From: Eric Friedman (ebf_at_[hidden])
Date: 2003-11-07 16:18:55

David Abrahams wrote:

> Eric Friedman <ebf_at_[hidden]> writes:
>>While some of the names are a bit longer, I feel the changes are
>>beneficial to the library.
>>I will soon update the documentation to reflect these changes.
> FWIW, I'm a little sorry I planted the "make_" prefix in your mind.
> It's usually only used for runtime functions, i.e. object generators
> (

I was worried about confusion that might result from simply calling the
metafunctions 'recursive_variant' or 'variant_over'. Though attempting
to instantiate these types directly (rather than their exposed ::type)
would immediately lead to an error, I feel it might be less than obvious
to the user why the error has occurred.

That is why I chose the make_XXX names. My intention was to echo names
such as mpl::make_identity.

 From the link you sent, it seems like the recommended names would be:

   ...and so on

I'm not sure these names are too obvious or clear, and they certainly
are ugly.

So I think keeping the make_XXX names is a good idea. What do you think?


Boost list run by bdawes at, gregod at, cpdaniel at, john at