Boost logo

Boost :

From: Eric Friedman (ebf_at_[hidden])
Date: 2003-11-12 18:38:46

Rene Rivera wrote:

> Dear Boosters,
> Did the one change Dave suggested of using the function template solution
> instead of the macro.. To avoid yet another BOOST macro...
> template <class T> inline void no_unused_variable_warning(const T&) {}

Why not just call it unused_variable?

Argument: It seems the intent is to explicitly document that the
variable is unused. The added benefit is that the compiler understands
this documentation. If we were just trying to silence the compiler, we
could turn off unused variable warnings.


Boost list run by bdawes at, gregod at, cpdaniel at, john at