Boost logo

Boost :

From: Rene Rivera (grafik.list_at_[hidden])
Date: 2003-11-12 19:12:55

[2003-11-12] Eric Friedman wrote:

>Rene Rivera wrote:
>> Dear Boosters,
>> Did the one change Dave suggested of using the function template solution
>> instead of the macro.. To avoid yet another BOOST macro...
>> template <class T> inline void no_unused_variable_warning(const T&) {}
>Why not just call it unused_variable?
>Argument: It seems the intent is to explicitly document that the
>variable is unused. The added benefit is that the compiler understands
>this documentation. If we were just trying to silence the compiler, we
>could turn off unused variable warnings.

The one reason I can think of to have the extra no_..._warning is to
document not just that the variable is unused, but that it causes a warning
because it is unused.

That said.. I'm happy with just about any name others think is best ;-)

-- grafik - Don't Assume Anything
-- rrivera (at) - grafik (at)
-- 102708583 (at) icq

Boost list run by bdawes at, gregod at, cpdaniel at, john at