Boost logo

Boost :

From: Rene Rivera (grafik.list_at_[hidden])
Date: 2003-11-13 00:35:06


[2003-11-12] Brian McNamara wrote:

>On Wed, Nov 12, 2003 at 06:12:55PM -0600, Rene Rivera wrote:
>> [2003-11-12] Eric Friedman wrote:
>> >Rene Rivera wrote:
>> >> template <class T> inline void no_unused_variable_warning(const T&) {}
>....
>> >Why not just call it unused_variable?
>....
>> That said.. I'm happy with just about any name others think is best ;-)
>
>I mentioned it before and I'll mention it again: I prefer

I remember ;-)

> disable_unused_variable_warning
>or
> disable_warning::unused_variable
>
>(When I see
>
> no_unused_variable_warning
>
>my first reaction is something like "Huh? The compiler doesn't have
>this warning, and this code is trying to compensate?")

Hmm, interesting.

When I see disable*warning I get the impression that it might be disabling
it from that point forward, not just for that one variable. And that I would
have to add an enable*warning someplace else.

But I would like to hear from more people as to what they prefer... Barring
that here's a quick census of what the various versions of this utility
other Boost libraries currently use...

concept_check, ignore_unused_variable_warning (Jeremy)
iterator_concepts, ignore_unused_variable_warning (Jeremy)
property_map, ignore_unused_variable_warning (Jeremy)
graph, ignore_unused_variable_warning (Andrew, Lie-Quan, Jeremy)
ublas, ignore_unused_variable_warning (Joerg, Mathias)
pool, uses (void)X instead of template function (Stephen)
type_traits, not_unused (John M.)
math, uses (void)X (Hubert)
numeric, ignore_unused_variable_warning (Herve)
lambda, dummy (Jakko, Gary) [not calling names ;-) - that's really the name
used]
multi_array, includes concept_check for the ignore_unused_variable_warning
(Ronald)
optional, unused_variable (Fernando Luis)
random, uses (void)X (Jens)
tuple, dummy (Jakko)
call_traits, unused_variable (John M.)

Seems the current popular choice is "ignore_unused_variable_warning".

Thoughts?

-- grafik - Don't Assume Anything
-- rrivera (at) acm.org - grafik (at) redshift-software.com
-- 102708583 (at) icq


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk