Boost logo

Boost :

From: Brian McNamara (lorgon_at_[hidden])
Date: 2003-11-12 23:07:36


On Wed, Nov 12, 2003 at 06:12:55PM -0600, Rene Rivera wrote:
> [2003-11-12] Eric Friedman wrote:
> >Rene Rivera wrote:
> >> template <class T> inline void no_unused_variable_warning(const T&) {}
...
> >Why not just call it unused_variable?
...
> That said.. I'm happy with just about any name others think is best ;-)

I mentioned it before and I'll mention it again: I prefer

   disable_unused_variable_warning
or
   disable_warning::unused_variable

(When I see

   no_unused_variable_warning

my first reaction is something like "Huh? The compiler doesn't have
this warning, and this code is trying to compensate?")

-- 
-Brian McNamara (lorgon_at_[hidden])

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk