Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2003-12-03 08:53:25

"John Maddock" <john_at_[hidden]> writes:

>> Do we need a separate config macro and a little test for this one?
> Unfortunately it looks like we do, further investigation reveals that the
> following statement:
> using boost::get_pointer;
> seems to poison ADL lookup for get_pointer in namespaces beneath boost,
> changing this to:
> using namespace boost;
> and you test case now compiles OK with this compiler!
> How about BOOST_POISONED_ADL_LOOKUP for want of a better name?

I think we can do better, but I need a better description of what
happens in order to get there. Can you give more details?


Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at