Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2003-12-27 02:02:28


1. Maybe you should rename the library. I haven't imagined:

    I wish I had a container of (smart) pointers that held polymorphic or
non-polymorphic objects.

But I have imagined:

    I wish there was a container that could hold objects that were scattered
across a class hierarchy.

Think of the solution space, not the implementation space

2. There are some constructors and assignments with

    Op( size_type n, T t );
    template < typename InIter > Op( InIter b, InIter e );

You have a way for the proper algorithm to be used when T == size_type?

-- 
Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT hotmail DOT com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk