Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2003-12-27 08:23:57


"Daryle Walker" <darylew_at_[hidden]> wrote in message
news:BC1298B4.43CF%darylew_at_hotmail.com...
> 1. Maybe you should rename the library. I haven't imagined:
>
> I wish I had a container of (smart) pointers that held polymorphic or
> non-polymorphic objects.
>
> But I have imagined:
>
> I wish there was a container that could hold objects that were
scattered
> across a class hierarchy.
>
> Think of the solution space, not the implementation space

Is this a riddle of some kind :-) I'm sorry Daryle, but I don't quite
understand. There is
one other name I have though of, smart containers, but that seems a bit
pop-smart.

> 2. There are some constructors and assignments with
>
> Op( size_type n, T t );

Op( size_type n, const T& t );

> template < typename InIter > Op( InIter b, InIter e );
>
> You have a way for the proper algorithm to be used when T == size_type?

not yet. There was some discussion on comp.lang.c++.moderated recently, but
I have not read up on it. If you do have a
ptr_container<size_type>, you will definitely get a ct error if something is
wrong. If you explicitly
cast the first argument to a size_type, the correct overload will be picked.
But I guess a small tag mechanism would do the trick.

br

Thorsten


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk