Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2004-01-01 13:03:21

On 12/27/03 8:23 AM, "Thorsten Ottosen" <nesotto_at_[hidden]> wrote:

> "Daryle Walker" <darylew_at_[hidden]> wrote in message
>> 1. Maybe you should rename the library. I haven't imagined:
>> I wish I had a container of (smart) pointers that held polymorphic or
>> non-polymorphic objects.
>> But I have imagined:
>> I wish there was a container that could hold objects that were scattered
>> across a class hierarchy.
>> Think of the solution space, not the implementation space
> Is this a riddle of some kind :-) I'm sorry Daryle, but I don't quite
> understand. There is one other name I have though of, smart containers, but
> that seems a bit pop-smart.

You can think of a class as:
1. How it is implemented
2. What problems it solves

You keep focusing on [1] (cool method of using pointers within containers).
As an user, I don't care about [1]; I only care about [2] (storing
Polymorphic Heterogeneous objects in the same container). Your naming could
reflect that (e.g. "ph_vector").

Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT hotmail DOT com

Boost list run by bdawes at, gregod at, cpdaniel at, john at