Boost logo

Boost :

From: Russell Hind (rhind_at_[hidden])
Date: 2004-01-08 03:53:05

David B. Held wrote:
> 3) There is a redundancy to your system which can be good or
> bad. You shouldn't have to say that m_div_s is a velocity. On
> the other hand, for very short names, like m or s, spelling out
> the dimension could be useful. It seems to me that perhaps
> users would typedef the most commonly used units, in which
> case it might not be bad to give them longer names, like so:

I can see that this redundancy may be useful. We deal sometimes with
wavenumbers (cm-1) which is actually a frequency (i.e. 100cm-1 == 3THz).
  I would hope that we could specify these units so that they couldn't
be converted to a length by inverting the value even though that would
give units of cm.



Boost list run by bdawes at, gregod at, cpdaniel at, john at