Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2004-01-13 06:13:04


Synchronisity ;-)

> > BOOST_PYTHON_NO_LIB: to turn off auto-linking (if supported).
> > BOOST_ALL_NO_LIB: turns off auto-linking (if supported)
> Why isn't this called "BOOST_ALL_NO_AUTO_LINK" or
> "BOOST_ALL_NO_FORCE_LIB_NAME"? "NO_LIB" doesn't sound like it has
> anything to do with disabling auto_link.

Good question: the naming could probably be better, it's too late to change
for this release though IMO.

> > BOOST_PYTHON_STATIC_LINK: forces static linking (probably use with
> > python already uses).
> It uses "BOOST_STATIC_LIB". I wonder why anything that generic was
> ever considered (by me) to be OK?

Yep, I used to have a few non-generic names like that in use as well,


Boost list run by bdawes at, gregod at, cpdaniel at, john at