Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-02-25 19:07:38

Daniel Frey <daniel.frey_at_[hidden]> writes:

>> Incidentally, it's almost always possible to detect whether the first
>> argument supports operator += or operator-=. That might be a good way
>> to decide whether to advance/regress it.
> If is_iterator yields false

There is no is_iterator trait AFAIK. And I wasn't suggesting that.
I was suggesting something more like is_+=able and is_-=able traits.

> this is good to distinguish the rest,
> yes. But the first question is, whether we want to enhance the 2-arg
> version of next/prior or if we simply rename them to
> e.g. advanced/regressed. I'd be happy with the latter. Comments?

I find those names rather awful for functions; no offense intended.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at