Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2004-02-29 21:31:56

On Sun, 29 Feb 2004 09:31:40 -0800, Eric Niebler wrote
> > Daniel Frey <d.frey_at_[hidden]> writes:
> >>I don't like the name of the function, as std_min doesn't hint me
> >>about the ADL-nature of the call. Would adl_std_min be too much
> >>typing? Or propbably just adl_min, as it's quite common to use
> >>std::min if ADL doesn't find a better match. My $.02.
> >
> >
> > Looks to me as though boost::min_ is the best name for this thing.
> >
> I tried to engage people in a discussion of these issues before
> making 1000+ edit to correct this problem. Now, everybody want to
> change it. :-P
> This would be a simple search/replace, so I don't mind. Can we all
> agree on boost::min_? I don't want to have to change it again.

No, I don't think it is worth changing again. min_ isn't better than std_min
in my view. Put extra comments in the code / docs to explain it. Changing it
again means all of us will have to re-integrate your new changes. It's
working, don't mess with it, lets move on.


ps: Thx for taking this on. I haven't personally had to deal with this nasty
bit of windows macro hell, but I'm sure it would have got me sooner or later.

Boost list run by bdawes at, gregod at, cpdaniel at, john at