Boost logo

Boost :

From: E. Gladyshev (eegg_at_[hidden])
Date: 2004-03-09 23:42:40

----- Original Message -----
From: "Douglas Gregor" <gregod_at_[hidden]>

> I suggest making capture_wrapper a function object wrapper, not a
> (slot_types aren't actually invocable as function objects):

I see.


> That'd be a much bigger change to Signals. For one, we'd be breaking the
> logarithmic complexity of inserting a new element in a particular group.

Yes, it would need to be a template template parameter for defining
the slot container type or a policy.


Boost list run by bdawes at, gregod at, cpdaniel at, john at