|
Boost : |
From: Pavel Vozenilek (pavel_vozenilek_at_[hidden])
Date: 2004-03-19 17:54:40
This should be starting point of discussions about proper indexed_set
naming.
indexed_set name was picked long before the library gained much more
functionality.
Instead of changing name immediatelly it was decided to wait on opinion of
others
(any change requires quite a lot of work).
Here are my suggestion of names, with rationale:
1. the data structure should be named "multi_container"
and should reside (or be lifted) in boost namespace.
Rationale: it is superset of std::set/multiset/list
and possibly slist and deque). Therefore the "multi".
The structure is important and will be probably
unique - therefore the boost namespace.
2. library specific names that won't fit into boost
namespace should be in "multiindex" namespace.
Rationale: it will be used mainly for index related
names. The name is aso reasonably short.
3. indexes should be named: set_like, multiset_like,
list_like, slist_like, deque_like.
Rationale: it gives idea to user what it is about (more
than e.g. sequenced).
4. Since indexed_set::unique may clash with std::unique
I suggest to use words "distinctive", "non_distinctive".
Rationale: I found it in a dictionary as the only
one word synonum to unique. English native comment welcomed.
/Pavel
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk