Boost logo

Boost :

From: Paul A Bristow (boost_at_[hidden])
Date: 2004-03-23 08:03:12

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Pavel Vozenilek
| Sent: 19 March 2004 22:55
| To: boost_at_[hidden]
| Subject: [boost] Naming Issues [part of Formal Review: Indexed Set]
| Here are my suggestion of names, with rationale:
| 1. the data structure should be named "multi_container"
| and should reside (or be lifted) in boost namespace.
| Rationale: it is superset of std::set/multiset/list
| and possibly slist and deque). Therefore the "multi".
| The structure is important and will be probably
| unique - therefore the boost namespace.
| 2. library specific names that won't fit into boost
| namespace should be in "multiindex" namespace.

The 'ii' looks a bit un-english.

I would use a hyphen - as I am sure would Lynn Truss of "Eats, Shoots
and Leaves' fame.
(I felt this about the documentation too)

So how about multi_index? Also consistent with "multi_container" where
a _ is used?

| Rationale: it will be used mainly for index related
| names. The name is aso reasonably short.
| 3. indexes should be named: set_like, multiset_like,
| list_like, slist_like, deque_like.
| Rationale: it gives idea to user what it is about (more
| than e.g. sequenced).
| 4. Since indexed_set::unique may clash with std::unique
| I suggest to use words "distinctive", "non_distinctive".
| Rationale: I found it in a dictionary as the only
| one word synonum to unique. English native comment welcomed.

I see no need for the suffix 'ive - how about just "distinct"?

The only other word that comes to mind with a similar meaning is "sole"

Unique is really unique.

Is there _really_ a clash with STL usage?


PS Truly English native speaker of english unsullied by the ex-colonials

Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539 561830 +44 7714 330204
mailto: pbristow_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at