Boost logo

Boost :

From: Miro Jurisic (macdev_at_[hidden])
Date: 2004-03-22 23:51:43

In article <uekrke8bn.fsf_at_[hidden]>,
 David Abrahams <dave_at_[hidden]> wrote:

> I see no reason to use names longer than those suggested below.

> > BOOST_GNU (1)
> > BOOST_MSVC (2)

I would suggest using BOOST_CC_* or BOOST_COMPILER_*, to avoid possible
ambiguities. For instance, BOOST_INTEL in and of itself does not make it clear
whether it denotes a compiler-specific kludge or an architecture-specific kludge.

If the full name of the macro is BOOST_FOO, then the assumption is that FOO will
never be ambiguous within boost. It is therefore a poor choice to make FOO
contain nothing but a vendor-chosen name, IMO.


If this message helped you, consider buying an item
from my wish list: <>

Boost list run by bdawes at, gregod at, cpdaniel at, john at