Boost logo

Boost :

From: Michael Glassford (glassfordm_at_[hidden])
Date: 2004-03-23 07:52:00

Miro Jurisic wrote:
> In article <uekrke8bn.fsf_at_[hidden]>,
> David Abrahams <dave_at_[hidden]> wrote:
>>I see no reason to use names longer than those suggested below.
>>> BOOST_GNU (1)
>>> BOOST_MSVC (2)
> I would suggest using BOOST_CC_* or BOOST_COMPILER_*, to avoid possible
> ambiguities. For instance, BOOST_INTEL in and of itself does not make it clear
> whether it denotes a compiler-specific kludge or an architecture-specific kludge.

I second this. In addition to being more consistent and eliminating
possible ambiguities, it would also make it much easier to search for
compiler-specific patches.


Boost list run by bdawes at, gregod at, cpdaniel at, john at