From: Paul A Bristow (boost_at_[hidden])
Date: 2004-03-24 07:03:02
Just because I'm English doesn't mean I am right ;-)
(But then nor does that mean that internet users are right either.)
I have glanced at the review notes but don't feel able to make any
helpful comment - except that naming is important but clearly especially
Consistency IS valuable though - it is irritating to try to remember if
a _ is needed or not - and I usually don't - leading to a blizzard of
warning messages from the oligo-neuronic compiler.
So I feel you should either go for always using multi_, or never. And
since STL already uses multimap, you should ignore my hyper-sensibility
about "multiindex" in names (and that would make it odd in the text).
(Aside - I don't like "mix" at all, but I do like ordered rather
Sorry this isn't much help.
PS At least english is unreceptive to authority and always receptive to
new words, preferably stolen!
Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539 561830 +44 7714 330204
| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Joaquin M
| Lopez Munoz
| Sent: 23 March 2004 14:31
| To: boost_at_[hidden]
| Subject: [boost] Re: Naming Issues [part of Formal Review:
| Indexed Set]
| Paul A Bristow <boost <at> hetp.u-net.com> writes:
| > | -----Original Message-----
| > | From: boost-bounces <at> lists.boost.org
| > | [mailto:boost-bounces <at> lists.boost.org] On Behalf Of
| Pavel Vozenilek
| > | 2. library specific names that won't fit into boost
| > | namespace should be in "multiindex" namespace.
| > The 'ii' looks a bit un-english.
| > I would use a hyphen - as I am sure would Lynn Truss of
| "Eats, Shoots
| > and Leaves' fame.
| > (I felt this about the documentation too)
| > So how about multi_index? Also consistent with
| "multi_container" where
| > a _ is used?
| This is supposed to be a brainstorming thread, so allow
| me to dissent here :)
| Lacking a solid English language intuition, I often use
| Google to try to find "best uses": "multiindex" yields
| 20,300 hits, while "multi index" only produces 15,400
| results. Note that "multi index" includes "multi-index"
| as well as other variants, so the case for "multiindex"
| seems to be even stronger than the raw figures show.
| OTOH, "multi-indexing" seems far more common than
| "multiindexing". Maybe we could stick with
| boost::multiindex and change "multiindexing" with
| "multi-indexing" in the text?
| multi_container seems to me awkward if compared
| to std::multimap. Why not multicontainer? Admiteddly, the
| "multi" prefixes do not mean the same in both cases, which
| could lead to confusion.
| Have you had a chance to take a look at the review
| notes? Some other alternatives are proposed there. I
| particularly like the boost::mix proposal, though others
| hate it.
| > Unique is really unique.
| > Is there _really_ a clash with STL usage?
| Yep. The following
| using namespace boost::indexed_sets;
| using namespace std;
| will raise the problem as soon as you declare
| an unique regular index.
| Joaquín M López Muñoz
| Telefónica, Investigación y Desarrollo
| Unsubscribe & other changes:
| http://lists.boost.org/mailman/listinfo.cg| i/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk