Boost logo

Boost :

From: John Torjo (john.lists_at_[hidden])
Date: 2004-05-04 10:21:41

Hi Thorsten,

about the name of the library:
Not sure why it's called collection traits, since IMO it should better
be called either sequence traits, container traits, range traits or
array traits.

>Please always state in your review, whether you think the library should be
>accepted as a Boost library!
it should be accepted into boost. I vote YES.

>- What is your evaluation of the design?
>- What is your evaluation of the implementation?
>- What is your evaluation of the documentation?
quite ok. Small suggestios:
- in collection_traits.html/"Semantics"
  You say '...c is an object of that type. SC will denote a standard
container...'. I think bullets would be quite ok here.

>- What is your evaluation of the potential usefulness of the library?
very useful in generic programming.

>- Did you try to use the library? With what compiler? Did you have any
yes, vc7.1, no problems.

>- How much effort did you put into your evaluation? A glance? A quick
>reading? In-depth study?
about two hours

>- Are you knowledgeable about the problem domain?

I love the result_iterator_of. Very useful.

I don't like the idiom of using begin() and end() for iterators which
default-constructed denote the end of a range. I think there are very
few iterator classes which match this concept: std::istringstream,
filesystem::directory_iterator, anything else? Maybe we could make it
more explicit, when using such iterator classes, to have a different set
of functions: end_it, begin_it?

Since we have value_of, iterator_of, etc., why not reference_of,


John Torjo
-- john_at_[hidden]
-- - viewing/filtering logs is just too easy!

Boost list run by bdawes at, gregod at, cpdaniel at, john at