Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2004-05-05 02:07:27

On Wed, May 05, 2004 at 09:10:48AM +0800, Joel de Guzman wrote:
> John Torjo wrote:
> >Hi Thorsten,
> >
> >about the name of the library:
> >Not sure why it's called collection traits, since IMO it should better
> >be called either sequence traits, container traits, range traits or
> >array traits.
> I agree. I think sequence traits is most appropriate.
You are not quite right. Sequence concept is precisely defined in C++ standard.
Collection traits are not implementig this concept, they don't even implement
full Container concept. So if would be very misleading to use the name of it.
Collection traits are working with structures that model Collection concept,
therfore they should be named after it IMHO.

As Thorsten already mentioned in the other post, name sequence traits is already
used elsewhere (in the string_algo library) to refine properties of sequences.



Boost list run by bdawes at, gregod at, cpdaniel at, john at