Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2004-05-07 05:37:33

On Fri, May 07, 2004 at 07:31:13PM +1000, Thorsten Ottosen wrote:
> "Pavol Droba" <droba_at_[hidden]> wrote in message
> | Would it make sense to move iterator_range to this library as well?
> | (given the fact it was requested to be separated from the string algo lib
> | during the review)
> yes, I was about to ask about that :-)
> | After all, it is a minimal encapsulation of the Range concept. If
> | the library will not be only about the traits, it might be natural to
> | put it there.
> yes.
> How about calling it range<> then?
> I think back then I suggested to call it range<>, but iterator_range was chosen because it was a range of iterators.

I would stick with iterator_range. Range for concept is fine. Concept is mainly a documentation
issue and there, it is easy to clearly state the affinity to containers.

It is not same for code entities like iterator_range is. IMO "range" is too broad term to be
used this.



Boost list run by bdawes at, gregod at, cpdaniel at, john at