Boost logo

Boost :

From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2004-05-07 04:31:13

"Pavol Droba" <droba_at_[hidden]> wrote in message

| Would it make sense to move iterator_range to this library as well?
| (given the fact it was requested to be separated from the string algo lib
| during the review)

yes, I was about to ask about that :-)

| After all, it is a minimal encapsulation of the Range concept. If
| the library will not be only about the traits, it might be natural to
| put it there.


How about calling it range<> then?
I think back then I suggested to call it range<>, but iterator_range was chosen because it was a range of iterators.



Boost list run by bdawes at, gregod at, cpdaniel at, john at