Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-06-04 13:39:13

From: Joaquin M Lopez Munoz <joaquin_at_[hidden]>
> Rob Stewart <stewart <at>> writes:
> > From: Joaquin M Lopez Munoz <joaquin <at>>
> > >
> > > For these reasons, I think allocator_rebind is not an
> > > appropriate name. Anyone suggesting a better name than
> > > allocator_helper? (Andreas? you wanted to use this stuff)
> >
> > Why not simply allocator_utilities.hpp?
> Yes, sounds good. Same name for the namespace
> (boost::detail::allocator_utilities)? Isn't it
> a little long?

Any reason why the ns can't be "allocator?" This code will
coexist with any allocator library that may appear, I should
think, and these should interoperate with such a library; it
might even become part of such a library. I can't see a problem
with them sharing a ns. (That also suggests that the directory
for the header is boost/allocator/detail.)

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at