Boost logo

Boost :

From: JOAQUIN LOPEZ MU?Z (joaquin_at_[hidden])
Date: 2004-06-04 15:53:31

----- Mensaje original -----
De: Rob Stewart <stewart_at_[hidden]>
Fecha: Viernes, Junio 4, 2004 8:39 pm
Asunto: Re: [boost] Re: New utility at boost/detail/allocator.hpp

> From: Joaquin M Lopez Munoz <joaquin_at_[hidden]>
> > Rob Stewart <stewart <at>> writes:
> > > From: Joaquin M Lopez Munoz <joaquin <at>>
> > > >
> > > > For these reasons, I think allocator_rebind is not an
> > > > appropriate name. Anyone suggesting a better name than
> > > > allocator_helper? (Andreas? you wanted to use this stuff)
> > >
> > > Why not simply allocator_utilities.hpp?
> >
> > Yes, sounds good. Same name for the namespace
> > (boost::detail::allocator_utilities)? Isn't it
> > a little long?
> Any reason why the ns can't be "allocator?" This code will
> coexist with any allocator library that may appear, I should
> think, and these should interoperate with such a library; it
> might even become part of such a library. I can't see a problem
> with them sharing a ns. (That also suggests that the directory
> for the header is boost/allocator/detail.)

That's too bold IMHO. We don't even know how a potential
future allocator library might look like to impose it
to receive this: more than a bequest to that library, this
stuff could be an inconvenient burden.

So, I propose


Later on, we're still free to move (or alias) this into
boost::allocator if it fits into that future allocator
lib. What do you think?

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo

Boost list run by bdawes at, gregod at, cpdaniel at, john at