Boost logo

Boost :

From: Doug Gregor (dgregor_at_[hidden])
Date: 2004-06-29 10:45:18

On Tuesday 29 June 2004 10:21 am, David Abrahams wrote:
> Doug Gregor <dgregor_at_[hidden]> writes:
> > Right, so what we have (I think) are reasonably well-designed classes
> > with incorrectly specified concepts. scoped_lock should really lock;
> > try_lock should just try to lock.
> I don't understand; are you addressing the concept problem above?
> scoped_lock refers to a class, right?

No and yes :)

At this point, we know that the concepts are inconsistent with the code. I'm
just saying that the concepts are wrong, and that the existing semantics of
the classes scoped_lock and try_lock (actually, it's called scoped_try_lock)
are the correct ones.


Boost list run by bdawes at, gregod at, cpdaniel at, john at