Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-07-03 09:48:11

Walter Landry <wlandry_at_[hidden]> writes:

> David Abrahams <dave_at_[hidden]> wrote:
>> * prod should be named operator*; this is a linear algebra library
>> after all.
> Actually, operator* can be thought of as either an inner product or an
> outer product. I'm not familiar with the innards of uBLAS, but that
> is a problem common to most linear algebra libraries.

IIUC in the domain of linear algebra when mathemeticians write


for 2D matrices A and B, they mean ordinary matrix multiplication (I
think inner product) yielding another 2D matrix, and that's what
operator* should mean in a linear algebra library. If you want an
outer product yielding a 4D matrix I think you're basically outside
the domain of linear algebra.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at