From: Vincent N. Virgilio (virgilio_at_[hidden])
Date: 2004-07-05 00:41:01
Walter Landry wrote:
> David Abrahams <dave_at_[hidden]> wrote:
>>* prod should be named operator*; this is a linear algebra library
>> after all.
> Actually, operator* can be thought of as either an inner product or an
> outer product. I'm not familiar with the innards of uBLAS, but that
> is a problem common to most linear algebra libraries.
> Walter Landry
> Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
I find that operator^ is an expressive syntax for the outer product. Of
course you lose a terse syntax for exponentiation; but perhaps that is
not important for the operands involved.
There is prior art, even on this list, in Jaap Suter's Geometric Algebra
-- Vince Virgilio
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk