From: David Abrahams (dave_at_[hidden])
Date: 2004-07-15 10:58:06
"Fredrik Blomqvist" <fredrik_blomqvist_at_[hidden]> writes:
> David Abrahams wrote:
>> I'm soliciting suggestions for the name of the member. All names with
>> suffixes like "_t" will be rejected, and be aware that base is
>> already taken for other purposes. Currently my thoughts are
>> super // super
>> crtp // ugly
> Why not something related to "iterator" and/or "adaptor"?
> iterator_adaptor_base? adaptor_base?
and iterator_facade_base or facade_base?
Hmm, I guess in case of multiple inheritance that approach is more
-- Dave Abrahams Boost Consulting http://www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk