Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-07-16 14:59:52

David Abrahams <dave_at_[hidden]> writes:

> "Fredrik Blomqvist" <fredrik_blomqvist_at_[hidden]> writes:
>> David Abrahams wrote:
>> [snip]
>>> I'm soliciting suggestions for the name of the member. All names with
>>> suffixes like "_t" will be rejected, and be aware that base is
>>> already taken for other purposes. Currently my thoughts are
>>> super // super
>>> crtp // ugly
>> Why not something related to "iterator" and/or "adaptor"?
>> iterator_adaptor_base? adaptor_base?
> and iterator_facade_base or facade_base?
> Hmm, I guess in case of multiple inheritance that approach is more
> useful.

OK, now done. The typedefs are iterator_facade_ and


Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at