Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2004-07-19 17:28:38

Rob Stewart <stewart_at_[hidden]> writes:

> Doesn't that argue for the case of making the "key" that
> indicates that the lock should be "non-locking" more explicit
> than a bool? IOW, if one is rarely going to write
> "scoped_lock(m, false)," then the meaning of "false" is even more
> obscure and "non_locking" is even more appropriate.

"non_locking" is a terribly obscure name to associate with a lock. I
really think "deferred" works well.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at