Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2004-07-20 08:30:00

From: David Abrahams <dave_at_[hidden]>
> Rob Stewart <stewart_at_[hidden]> writes:
> > Doesn't that argue for the case of making the "key" that
> > indicates that the lock should be "non-locking" more explicit
> > than a bool? IOW, if one is rarely going to write
> > "scoped_lock(m, false)," then the meaning of "false" is even more
> > obscure and "non_locking" is even more appropriate.
> "non_locking" is a terribly obscure name to associate with a lock. I
> really think "deferred" works well.

I can't disagree. I was just using the name already being

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at